Problem w/ 3.02 Install

Oct 24, 2007 at 4:38 PM
Edited Oct 24, 2007 at 5:14 PM
I've installed 3.02 on Windows 2003, and followed the directions to the best of my understanding. Everything works well until I try to use the "Add Work Items" button from the Timesheet tab. What's interesting is that if I run it from localhost, it works. However, if I run it using the server name/URL, I get the error below. I assume this has something to do with either my database connection or my identity. Any ideas?

The network path was not found.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Runtime.InteropServices.COMException: The network path was not found.


Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:


[COMException (0x80070035): The network path was not found.
]
System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail) +610
System.DirectoryServices.DirectoryEntry.Bind() +36
System.DirectoryServices.DirectoryEntry.get_AdsObject() +31
System.DirectoryServices.PropertyValueCollection.PopulateList() +25
System.DirectoryServices.PropertyValueCollection..ctor(DirectoryEntry entry, String propertyName) +92
System.DirectoryServices.PropertyCollection.get_Item(String propertyName) +131
Stratman.Web.VSTS.UI.Pages.Timesheet.Add.GetBreadCrumb() in C:\Development Projects\C#\Stratman\Web\VSTS\UI\Pages\Timesheet\Add.aspx.cs:93
Microsoft.TeamFoundation.WebAccess.UI.Masters.Content.RenderPage() +564
Microsoft.TeamFoundation.WebAccess.UI.WebAccessPageMaster.OnLoad(EventArgs e) +19
System.Web.UI.Control.LoadRecursive() +47
System.Web.UI.Control.LoadRecursive() +131
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1061


Oct 26, 2007 at 2:41 PM
I'm guessing this whole thing is a big bust. Not only can I not resolve the issue above, it appears that if someone updates a work item more than once a day, you get multiple entries in the database, thus skewing the results wildly. Unless someone can point out the folly of my ways, I'm dumping this.
Nov 1, 2007 at 5:48 AM
I also am experiencing the same problem with the 3.02 version. Everything is working fine if I access the TimeSheet using the machine where I installed the TeamPlain Web System. But when I used another machine in the network to access the Timesheet tab and click the 'Add Work Items'. I get the same exception mentioned by jroth.

Any ideas?

Thanks!
Coordinator
Nov 13, 2007 at 8:15 PM
The problem with the "Add Work Items To Timesheet" page should be resolved: when I removed the LDAP lookups for the user's display name from project, I neglected to do so for that page. As for the problem with multiple entries being created in database for time updates to a work item, I'm not sure what you mean: each user that updates the time for a work item will have an entry created for themselves, but multiple updates to a single work item by a single user should be added together in a single entry. If you can give me some example data that you're seeing in the tables, then I might be able to investigate further.
Nov 13, 2007 at 9:22 PM
Thanks for the first part - yes, it fixed the remote issue.

As for multiple updates, I'm seeing complete discrepancies. For example, on one work item, my programmer entered Completed Work of .5, 3.5, and 9 hours, respectively. Timesheet shows 16:30!!! This results in wildly skewed results.

Any ideas on what's wrong? What tables would you like to see data from?

jr
Nov 13, 2007 at 9:31 PM
187 2584 S-1-5-21-854245398-1202660629-839522115-427135 1.5000 11/7/2007 12:00:00 AM
196 2584 S-1-5-21-854245398-1202660629-839522115-427135 9.0000 11/8/2007 12:00:00 AM
210 2584 S-1-5-21-854245398-1202660629-839522115-427135 16.5000 11/12/2007 12:00:00 AM

These are the 3 entries in TimesheetEntries for the work item (2584) above. I don't have a clue where the 16.5000 entry came from!

Here's the entry in WorkItemTotals for that work item:
2584 S-1-5-21-854245398-1202660629-839522115-427135 27.0000

That looks right, but I don't know where the 16.5 hour entry came from.