No Authorization

Jun 6, 2008 at 2:25 PM
When I copy the web files to my existing team system web access ver 9.0 engl. I get a logon dialog but no user id is accepted. iisreset or restarting service team system web access does not effect. I thing I've changed web.config correctly, but I am no web expert. If I copy back original web access everything is fine again.
What meight be the problem?

Ive installed TFS 2008 engl. on a windows 2003 server engl. with timesheet 3.02 for 2008. Web access 2008 is installed using windows authorisation.
Coordinator
Jun 6, 2008 at 7:52 PM
Can you run a diff against the two config files to determine the exact lines that were changed?  It will help narrow down the potential problem areas.
Jun 8, 2008 at 11:26 AM
Here the differences in bold. But I also get a web page not available message, if I restore the original web.config:

 

<?xml version="1.0" encoding="UTF-8"?>

<configuration>

 

  <configSections>

    <section name="webAccessSettings" type="Microsoft.TeamFoundation.WebAccess.Common.WebAccessSettings" />

  </configSections>

 

  <!-- Timesheet configuration DK20080604 -->

  <connectionStrings>

    <add name="TimesheetDatabase" connectionString="Server=(local);Database=TfsTimesheet;User ID=TimesheetUser;Password=password"/>

  </connectionStrings>

 

 

  <appSettings>

    <!-- Directory path where cache is stored. -->

    <add key="WorkItemTrackingCacheRoot" value="C:\Program Files\Microsoft Visual Studio 2008 Team System Web Access\Cache"/>

    <add key="TfcBin" value="c:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\PrivateAssemblies" />

 

    <!-- Timesheet configuration DK20080604 -->

    <add key="TimesheetAdministrators" value="domain-name\dkamps;TFS\administrator"/>

    <add key="TimesheetWorkAmountFields" value="Microsoft.VSTS.Scheduling.CompletedWork="/>

  </appSettings>

    <httpHandlers>

      <add path="Reserved.ReportViewerWebControl.axd" verb="*" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" validate="false"/>

      <!--<remove verb="*" path="*.asmx"/> DK20080604 -->

    </httpHandlers>

</configuration>

 

Coordinator
Jun 8, 2008 at 3:51 PM
Are you getting the logon dialog when you try to access the timesheet pages or when you try to do anything in TSWA at all?  If it's only the timesheet functions, check the permissions on all of the files that you deployed to the TSWA server to make sure that the aspx pages and the DLLs are all accessible.  If they are, try running process monitor (http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx) to see if you can figure out what TSWA is unable to access, causing it to display the logon dialog.
Jun 9, 2008 at 6:19 AM
Edited Jun 9, 2008 at 8:01 AM
No sorry, it is the TSWA at all. I get the logon dialog directly after aceessing to the start page.

But after reinstalled TSWA and Timesheet and solved some sql server trustee (changing from windows authentication to both SQL and windows authentication and assigning some more roles to timesheet user) we now get full access.

But now Timesheet does not execute any query (in Timesheet and Work Items Tab as well). Message : Object reference not set to an instance of an object. And we cannot view any report.

If we restore original Web.config we get the same error on tab work items, but if  we restore original TSWA the querie will work fine.
Coordinator
Jun 9, 2008 at 1:19 PM
Check the event log on the TSWA server to see if any Team System errors show up.  You should also uncomment the system.diagnostics section in the web.config so that verbose debugging information is written to a log file (path is in the same section).  If that doesn't work, you may want to download the source to this project, compile it in debugging mode, deploy it, and set up remote debugging as instructed in this article:  http://msdn.microsoft.com/en-us/library/bt727f1t(VS.80).aspx.  Once you have that enabled, you'll be able to break into debugging mode when the exception occurs and figure out what's going on.
Jun 10, 2008 at 7:49 AM
verbose debugging:

Configuration: [Error, P 6088, T 1100/1, A 21083178, S tb14yo3wdcjtdovlvxqcue45, 6/10/8 06:41:34.681] { Unable to write user settings to file C:\Program Files\Microsoft Visual Studio 2008 Team System Web Access\Web\App_Data\Settings\UserSettings\administrator.tfs.config.
Ausnahme: {
Exception Message: Access to the path 'C:\Program Files\Microsoft Visual Studio 2008 Team System Web Access\Web\App_Data\Settings\UserSettings\administrator.tfs.config' is denied. (type UnauthorizedAccessException)

so we gave all access rights in IIS Web Side Home directory and  all file rights to tfsservice user but the same error occures.

sorry we do not have any web programming skills.