followed Readme.txt but have to keep re-installing TSWA

Sep 25, 2008 at 12:57 AM
My install of TSWA worked great and the website comes up with no problems...until I try to install the TFS Timesheet component.

I followed all 7 steps of the ReadMe.txt document.  However, when I launch the website, it keeps prompting me for a password and the application pool is eventually disabled and the page can't be displayed.  Even after I restart the application pool, the same thing happens over and over until I re-install TSWA.

Whatever is going with the new Web items I copy over is ruining my TSWA installation.  I've tried different versions of the TFS Timesheet component but the same thing happens.  Why is it stopping the TswaPool1 Application pool?

Oct 2, 2008 at 12:00 PM
Same Problem With TFS2008, TSWA2008 and TFSTimesheet-3.02-TSWA2008
after BsSubscribe I get this message "TF50001:  Created or found an existing subscription. The subscription ID is 5." and when I launch the website, it keeps prompting me for a password,  in event log I have this Warning in system

Event ID: 1009
Source: W3SVC
Description:
A process serving application pool 'TswaPool1' terminated unexpectedly. The process id was '3128'. The process exit code was '0x800703e9'.

any idea?
Oct 22, 2008 at 3:52 AM
Yes...Just fixed it.   The Timesheet app binds to the "non-SP1" DLLs.  Here are the steps I took to make it work:

  1. Apply SP1 to my development macheine
  2. Install Team Foundation Web Access SP1
  3. Download the TFS 2008 source code from this site and extracted to local folders
  4. Update the "Lib" folder with the SP1 versions of assemblies.  The references are relative to the "Lib" folder not the shared assemblies.
  5. Publish the website to a temporary folder.
  6. Copy the Web folder to the Team Plain host MINUS the bin folder and the Web.config
  7. Copy the Stratman.* files from the temp bin folder to the Team Plain host web\bin folder seperately (I don't know if this is overkill but....)
  8. Restart IIS

These steps worked for me.  The ultimate solution is to simply post a new version with these steps applied

Nov 16, 2008 at 5:20 PM
Hi,
I managed to install in a TSWA SP1 one tier configuration with the above modfication:
Codebehind="PageHeader.ascx.cs" was missing from UI\Controls\PageHeader.ascx
Feb 9, 2009 at 6:08 PM
I am having trouble with SP1.  I have tried following the steps listed in this post, but still am unable to get TimeSheet addon to work. 

I have downloaded the code and updated the references to the new version of the Web Access assemblies.  I published the project and copied the files.  I am getting a not found error accessing the Timesheet files(http://localhost/UI/Pages/Timesheet/Explorer.aspx).  The files exist, so I am not sure where to go from here.  Side Note: I have limited experience with ASP.Net projects.

Kevin
Feb 9, 2009 at 7:58 PM
This sounds like a directory permissions error or anonymous access for IIS is not setup correctly.  What version of the OS are you running this on?
Feb 9, 2009 at 8:04 PM
That is what I was thinking.  I double checked and they appear to be correct.  I installed Web Access to my dev PC and have it pointing to our Dev TFS server.  Running TSWA without the mods it works with our TS dev server just fine.

XP SP3

Kevin

Feb 9, 2009 at 8:26 PM
the Not found also comes from an assembly not found.  Try putting a regular HTM page in the same folder and trying to browse to that.
Feb 9, 2009 at 10:07 PM
I figured out what the issue with not finding the page.  Since I was running in a virtual directory, it was navigating to a page that didnt have the VD in the path.


Another question I have is, what version of the code is working?  The version that is part of the 3.02 release version or the latest version from the Source Code tab?

The closest thing I have to anything working is with the source code released with 3.02, but I get a
"Format of the initialization string does not conform to specification starting at index 59."

when I navigate to the Timesheet tab.

Kevin

Feb 9, 2009 at 11:08 PM
That was going to be my final suggestion.  I'm glad you solved it.  I don't remember the version offhand that was my base. I've uploaded my working "compiled" website to http://www.EdgelandTech.com/downloads/TFS2008WebAccessSp1.txt  (rename to .zip and unzip it).  If you want source email me at TfsTimesheet@edgelandtech.com and I'll reply.

James