Unable to save time changes

Apr 30, 2009 at 5:45 PM
Hello,

I have TFS 2008 installed on a VM for testing. I have added Conchango's Agile template 2.2 +. Everything there is working fine. I added Timesheet  (TFSTimesheet-4[1].01-TSWA2008SP1) to this environment.

For my TFS Setup account I can add work items to the Timesheet, but cannot save any time. For my developer account I cannot even get the work items to add nor is there a save button available. I get no error messages.

Please help me find what the problem could possibly be?

Thanks

Yrik
May 5, 2009 at 5:02 AM
Hi Yrik, I'm making progress but dealing mostly with permissions and authentication issues - of which I suspect yours is an example.

If you edit the file "explorer.aspx" to include the following code:-

<!--<%
Response.Write(String.Format( Request.LogonUserIdentity.Name.ToString() ));
%>-->
after line 325 (the spot doesn't really matter)

 


Displaying the timesheet tab of TSWA - view the page source and you should see domain\username info that the application is using.

For me this tells me that even when a domain user logs in the system is thinking they are someone else.

Thx

 

May 5, 2009 at 3:31 PM
Thank you badcop666. I have added this code. When I go to the timesheet tab and view source I see the domain\user. The interesting thing is this is always the Windows user. For example if I log in to my PC as TFSSETUP, my user is TFSSETUP, even if I signout of TFS web Access and log back in as YRIK. I would have expected the web access to acknowledge the login user for its authentication. It is pointing me to permissions and authentication as my problem, but I am not yet clear as to what I need to fix.
May 11, 2009 at 3:57 PM

Time will not save through the TSWA if the "TimeAmounts" are not properly set up for synch with both the TFStimesheet database and the orignal TFS database. I am still trying to figure out how the the "TimeAmounts" drop down box selections were origianlly intended to be used. Right now I have chosen to just use the original default CompletedWork and Remaining work descriptions.

May 13, 2009 at 4:15 PM

Thanks everets. I am using TimeAmounts in their default state. When you say "synch" both databases, do you mean I should have another database connection string in my web.config or is there another way to synch them?

May 15, 2009 at 9:10 PM

At this point my only success has been when the TFSTimesheet database and the other databases in TFS are all using the default "completed hours worked" and "remaining hours worked". Any effort to use any other type of Timeamount fails for some reason at least for me. I all still having a total failure in getting the TSWA to update the "workItemsTotals" table. I can get it to update from the IDE if I change the hours, but noting I do in the TSWA web interface will touch the  "workItemsTotals" table. There must be a serious undocumented problem here as everyone I talk to is having major problems in these areas.

May 28, 2009 at 6:24 PM

I have tried everything suggested and still I cannot get the web page to post any information to the database.